TFT Binance Chain bridge broken? [RESOLVED]


I tried to send some TFT via the Binance Chain bridge to my MetaMask wallet.

I know how to do it because I already did it several times in the past.
The memo and destination address are correct because I’ve scanned the QR code with the THREEFOLD CONNECT app.

Unfortunately the coins did not arrive in my MetaMask wallet (BSC).
I’m already waiting since an hour.

This is the transaction:

It shows “successful” but my wallet still shows 0 TFT.

Please let me know. Thanks!

Hello @gogo76227,
There seems to be a problem with bridge’s connections to other BSC peers.
Will keep an eye on it and pick it up when operations guys are awake ( It’s only 4:54 am here).

Thanks for the info, especially in the middle of the night! :slight_smile:

Good morning, was someone able to look into this? The sent TFT does still not show up in my wallet.

Hey @gogo76227! We’ve followed up with the dev team for updates on the bridge issue, and it appears the fix is still being worked on. We acknowledge your urgency and sincerely apologize for any inconveniences during the time undertaken to resolve.

Hey yadalamahendra, thanks for the info. As long as you are working on solving it. I’m fine!

1 Like

We appreciate your patience @gogo76227 :pray:

1 Like

There was a BSC hard fork so the bridge’s BSC nodes had to be upgraded.
The bridge is currently catching up and we’re keeping an eye on it.

Thanks for the info, Rob! So I just have to wait until the TFT will arrive, because it still hasn’t yet…

It looks like nothing is moving at the address where my TFTs ended up…

Do you have any idea when I will get them back? I did nothing wrong and was just using the BSC bridge.

From the bridge logs, we have been able to identify there are indeed issues finding suitable BSC peers. Generally, these are temporary situations that lead up to 2-3 days to resolve, however, BSC tends to hard fork a lot and release new versions. As a result; on this occasion, it appears to be taking longer than usual.

Operations had a hard time with the new BSC fork.
Their full nodes are in sync but the bridge’s light node was unable to continue from where it stopped and they had to clear it’s data, having it resync from genesis again.
That’s why it’s taking so long.


Thanks Amanda and Rob, hope it will be solved soon… The TFTs are not yet showing up in my wallet.

1 Like

Hi, the bridge is operational again and your TFT’s should now be in your metamask wallet


Hi smetl, yes, thank you! Everything good now. :slight_smile:

1 Like