3SDK Simulator Installation help needed (WIN10)

Need help with the 3sdk: I just downloaded the most recent sdk version 10.5.1 for Windows.
I also have installed Docker for Windows Toolbox according to these instructions on my laptop that runs Win10 Home 1909: https://thewebspark.com/2019/04/04/how-to-install-docker-on-windows-10-home-edition-solved/
SDK starts without any issue but loading the Simulator fails:

Just FYI: With the previous version of the sdk (10.5), I had a different error message coming up:

Hi @pkgraz ,

Currently we only support Windows 10 64-bit: Pro, Enterprise, or Education.

You can find the updated docs for the requirements for windows here:
https://github.com/threefoldtech/jumpscaleX_core/blob/development/docs/3sdk/3sdk_install.md#requirments-for-windows

Thanks

Hi ahmed, same results and error message when I run the 3sdk on my desktop with Win10 Pro.

This is my system:


This part of the installation guide did not work:
grafik

ssh-add does not work:

and ssh-agent refuses to start on right-click:

Hence, still the same error message as reported before:
grafik

Thanks for your help
Peter

Hi Peter, I am not a windows user and It has been years since I touched it. Researching on the internet I fond this article: https://docs.microsoft.com/en-us/windows-server/administration/openssh/openssh_keymanagement

Many thanks for the hint Weynand - it brought me a bit further.
Following your link did not work, unfortunately, because of a download error from that site.
But I found another site that explained how to install Openssh and that worked, so I got the agent running eventually. https://www.wintotal.de/tipp/ssh-windows/ The site is in German, unfortunately, but the steps listed WORKED nicely.

with that, now also the ssh-addcommand worked.
Then I downloaded the new sdk 10.5.2 and running the command “simulator start” brought me a bit further, to a new hurdle:


Now, I get asked for my ok to generate a default ssh key, although I have already generate that key manually via ssh-keygen -t ecdsa -b 521 and ssh-add before I started 3sdk.
When I accept and hit yes, I get the error message shown in red above. If I hit no, 3sdk says "CANNOT… " for a second and closes the sdk completely.

Further help glady apprechiated, many thanks, Peter

bug created, its clearly not good enough

Thanks Kristof, I found what I did wrong, but then hit the next hurdle.

Above issue of ssh generation question I solved the following:
in Powershell, when I generated the keys manually via ssh-keygen -t ecdsa -b 521 and ssh-add, I entered a file name before (which was not necessary).
When I just hit enter, it works, and I don’t get asked the question to “generate a default ssh key”
grafik
-> where Powershell asks to enter a file (red above) just hit enter!

Restarting 3sdk and “simulator start” hits the next hurdle:

Error message copied here:
Error in executing docker run --name=simulator --hostname=simulator -d -p 9005-9009:8005-8009 -p 7000:80 -p 5000:8888 -p 4000:443 -p 9001:9001/udp -p 9000:22 --device=/dev/net/tun --cap-add=NET_ADMIN --cap-add=SYS_ADMIN --cap-add=DAC_OVERRIDE --cap-add=DAC_READ_SEARCH -v C:\Users\peter_000\sandbox\code:/sandbox/code -v C:\Users\peter_000\sandbox\myhost:/sandbox/myhost threefoldtech/3bot2 /sbin/my_init: Traceback:
docker: Error response from daemon: status code not OK but 500: {“Message”:“Unhandled exception: Drive has not been shared”}.
See ‘docker run --help’.

Many thanks for your help

Sorry, just managed that next hurdle myself by enabling file sharing “C” in my Docker desktop.
grafik
Simulator container is runnig, but Jumpscale is missing apparently…

@pkgraz Have you installed Git for Windows and also configured it as mentioned in the docs :

https://github.com/threefoldtech/jumpscaleX_core/blob/development/docs/3sdk/3sdk_install.md#git-for-windows

Hi Ahmed,
yes, I did install Git for Windows now, following the instruction to use LF line endings.

Then did run sdk simulator start again:

Then I also did run the following commands:

mkdir -p ~/sandbox/code/github/threefoldtech/
cd ~/sandbox/code/github/threefoldtech/
git clone -b development https://github.com/threefoldtech/jumpscaleX_core/
cd jumpscaleX_core/install

![grafik|690x402](upload://6I1ZSflTcYeIjRXSqHe3uzvxL3e.png) 

and tried 3sdk simulator start again with the following result:
![grafik|554x202](upload://xNFhmbblvUXk1cO0x7UlUAXQlTd.png) 

so coming closer - but still not there yet...


first screenshot did not upload correctly, sorry

grafik
this is the second screenshot above with where I currently stand…

I did also install Python3 and Pip3 on Windows:
https://phoenixnap.com/kb/how-to-install-python-3-windows
and
https://www.python.org/downloads/windows/
then upgraded pip3 to the latest version:
python -m pip install --upgrade pip

Then - important - installed the wheel package:
pip install wheel

Then these commands executed also on Windows without error or reporting missing items:

mkdir -p ~/sandbox/code/github/threefoldtech/
cd ~/sandbox/code/github/threefoldtech/
git clone -b development https://github.com/threefoldtech/jumpscaleX_core/
cd jumpscaleX_core/install
# On **Windows**
pip3 install -e .

But still some issues prevent the simulator to start:
grafik
grafik

any further guidance, please??? many thanks, Peter

@pkgraz , You can try the latest version of 3SDK for Windows here :

https://sdk.threefold.io/#/3sdk_windows

Make sure to delete the previous sandbox dir in your home/user folder , ssh-agent started, key loaded and Docker Desktop Daemon running.

Hi Ahmed,
meanwhile I was able to install the latest version of the sdk – 10.5.3 – in my Win10 desktop PC and it starts up without any error message.
My remaining issue is that the localhost connection is failing.
Browser is Chrome Version 83.0.4103.61 (Official Build) (64-bit)

Andreas Hartl said that this might be because of security settings in Chrome. What do I need to change, please?
many thanks for your help,
Peter

Hi @pkgraz,

It works pretty well on chrome , without any security settings required , unless you have made some custom settings.

Can you try with https to see if it works , also check the Docker Desktop(Dashboard) and see the container and its ports.

Thanks

Dear Ahmed,
as I was still unsuccessfull to start the 3sdk with the native Win10 version due to the issue to start up the localhost, I tried a different approch to run the sdk on my Windows PCs:
I simply installed the sdk all manually in a VM on Windows 10, once with Hyper-V (on my desktop with Win10 pro) and also on Virtual Box (on my Laptop with Win10 home).
Both worked well, took about 30min to set up. Hence I attach a short cookbook (für Linux beginners like myself)…

3sdk setup in VM on Win10.pdf

1 Like

Hi Peter,

Our 2.2 is online and ready to be tested, its all much more easy now.
Do you want to test and part of the early adopter team?

If yes can you join on: https://t.me/joinchat/BwOvOxxgK59GmRoZ2_sM0w

thanks

Kristof