The new playground

Did you check the section Contracts?
If you have the ip address (ipv4 or planetary) you could also try to ping it. It is indeed perhaps down.

1 Like

All nodes are up and running again but now the Threefold Presearch Playground Dashboard does not show a single node anymore…

Anything shown in Contracts?

I’ve just looked into “Contracts”, for the first time, I have to admit… :slight_smile: but all the nodes are now visible again and all the contracts are also visible. Not sure what exactly happened, but it’s all working again.

1 Like

Good to know. We’ll be on the lookout if this happens again and then we could find ways to fix it.

If it’s fixed for now, good! It might be that the nodes were down.

1 Like

The likelihood that all the nodes were down at the same time seems to be very low. I’ve set them up in several different countries… I’ll let you know when it happens again.

1 Like

I agree good point.

I wrote an issue on Github:
Let’s see if it helps the dev to troubleshoot/test the weblet for a future release.

Thanks a lot @gogo76227 ! That’s how we can improve the weblets, with feedback such as yours.

1 Like

Hi Mik,

I do have a new, very weird problem.

Until yesterday I had deployed 7 Presearch nodes - all of them were working perfectly. Then one in Poland stopped working - and didn’t show up in “Presearch Instances” anymore. I just got the “Failed to load 1 deployment…” warning.

Because it’s easy to deploy a new node I’ve started a new one in another country and waited for it to show up on the Presearch nodes website but it never did. So I looked up the contract of the node in Poland on TF Playground that wasn’t the first one not working and deleted it, but nothing changed, means new nodes would never show up on the Presearch nodes website.

Meanwhile I’ve tried several nodes in different countries with IP certified and without, waited the whole night - but none of them is showing up on the Presearch website.

6 nodes are still working fine but I can’t add another one that would show up on the Presearch website.

Do you have any idea what the problem could be?

OK that is intriguing. First know that the issue shared above is now being investigated (the Failed to load 1 deployment issue).

As a troubleshoot test, can you try this from the manual?

Then if possible please share here the output you get. This would be a good way to troubleshoot for non IP address nodes you deployed on.

We added this in the manual thanks to your feedback in this post. (here)

Hi Mik,

I read the

Then I’ve tried to connect to several IPs of the still running Presearch nodes via

ssh root@<VM_IP_Address>

I got the according IPs from the Presearch Node Status website.

As a result I’m getting:

ssh: connect to host <VM_IP_Address> port 22: Connection refused

Presearch provides a Public Key but I’m not familiar with how to use it.

I also got another “Failed to load 1 deployment” error and now only 5 of my originally 7 nodes are alive.

PS: I’ve again tried to add other certified nodes located in several different countries… and first it did not work. Now I was actually able to do so, but again something weird came up… I could only successfully set up certified nodes from Belgium. Three Belgian certified nodes are now up and running.

PSPS: I will leave the contract of the node that is causing the “Failed to load 1 deployment” error active for today and tomorrow, so that you might be able to find the problem.

The public key from Presearch must be something different

To SSH into the deployment, you need to set a SSH key pair and put the public key in the profile manager of the Playground. You can read this for more details:

If you have this error (connection refused), it might have to do with setting the proper public key in the playground.

You can also try to ping the address of the vm before doing SSH. If you can’t ping it (do not get a response from ping), then the VM might be down.

ping -c 2 <VM_IP_address>

The failed to load 1 deployment is still being investigated. I’ll let you know if there are news on this.

1 Like

Hi Mik,

I didn’t have much time in the last two weeks… Just now I had a look and had again “Failed to load 1 deployment…” . I also saw on the Presearch website that one Presearch node was down.

I had a look into the Playground-Presearch and got a message which was difficult to read (because of the used colors) that I think 3 of my contracts were old (or something similar). So, I deleted all old contracts and deployed a new node to get rid off the “Failed to load…” error message and to have 7 nodes running.

Right when I pressed “Deploy” for the new node, all my Presearch nodes on the Presearch website went offline at the same time!

Then for approx. one minute the newly deployed node came online (on the Presearch website) and went offline right afterwards.

Now all nodes are offline on the Presearch website - and in the Playground all of them show “No Data Available” which normally means they are not (yet) online… I also can’t ping them because I don’t know the IP addresses.

I might delete all of them and start from scratch - or what do you think?

A few minutes after posting this I got the following…

While the contract section shows:

and I do have enough TFT for several months in the wallet.

Usually it’s better to deal with the contracts in the weblet page (here Presearch) instead of the Contracts List.

Do you remember what the message was saying? If you deleted contracts related to the presearch deployments, it most certainly affected them. You might have to redeploy them in this case.

Also, note that you can ping the nodes via Planetary Network IP. (e.g. ping -c 4 planetary_IP).
You can download the TF Planetary Network Connector and then you can ping the address (see the manual here). Before deleting such contracts, next time you could try to ping the deployment to see if it works.

I just pinged them all, and they all responded. So the nodes are up.

Thanks. Will do so in the future :slight_smile:

It was barely readable because it was in light red on white - and I’m using dark mode. It was something about contracts, but it was only visible for a few seconds.

Thanks again!

I’ve now set up 7 new nodes and they are up and running.

For whatever reason it takes a while to find nodes that are actually showing up in Presearch. I think it has something to do with speed requirements of Presearch, because the faster* the nodes got deployed the likelier it was that they were actually working.

*= the time span after pressing the “Deploy” button until the node is ready.

Hi Mik,

My Presearch Nodes don’t show the “Cost” anymore, actually since some time. I’m still getting charged but I have no clue how much. This also means I can’t unlock any discounts because I don’t know what my monthly charges are.

Is is still happening?

Which playground URL are you using?

You can also always use the calculator on to check the cost.

This might fix itself once we push new changes to main net, which is in the following days.

1 Like

I’ve just reloaded the website - and yes, it still shows “No Data Available”. I really would like to know, also because I would like to see if I’m getting the mentioned discounts.

In the past it did show the exact price in TFT.

Ok. I will create a github issue so we can investigate.

Can you tell me which nodes you deployed on? And any other info relevant to the deployments. Thanks!

Note: this discussion is now continuing here: Presearch Not Displaying on Playground

I would like to add to the issue with presearch and the playground. I have found that it is difficult to get it running. And it frustrates me sometimes, that it takes a day or 2 for something that could be done in 5 min.
Problem 1: when adding your information or selecting the country or farm, it gets stuck validating (next to the tab base) This happens a lot!
Problem 2: if I get lucky to get the information loaded and deploy a node, I sometimes get the error message about missing node id when trying to create the contract.
Problem 3: the playground has issues loading the contracts (active contracts) or no data available.
Problem 4: this happened only a few times, but I couldn’t sign into my account after opening the site

This has been going on for a while now. I didn’t have these issues with the legacy version.

Hope it can get fixed soon.


Thanks for the feedback. That’s what we want: information!

A new and improved version of the Playground will soon be available.

Many if not all of those issues have been taken into account.

Having some aspects of the legacy version workflow was also taken into consideration. The deployment process should be much smoother.

To explore on dev net: