Network card not detected - dell poweredge r620 (CLOSED)

Hi guys,

in zero OS I get the failure message “No network card found” and it reebots after 20 seconds. Same for every LAN input. Its blinking green.
Its a Dell Poweredge R620 server. I have two. For the other one everything works fine.
I cant find anything related to network cards in the BIOS or Setup of the server.
Little bit lost here. Bios is up to date (2.90).

Thanks for any help.

1 Like

What network devices are you working with?

Often you will find them under your pci bus setting.

Also, if your using the port that attaches to the management network I would grad a different one, the management net can cause ip conflict and routing issues if its trying to pull on the same nic

1 Like

Did you try resetting the BIOS settings?

Sometimes it’s in Load Setup Defaults

Here’s a guide with bios settings for R620/R720:

If all this doesn’t work, maybe you can simply change the NIC card.

Did you plug the Ethernet cable in that port?

Also, maybe the drivers for the NIC card are not installed:

  1. Go to support section
  2. Download drivers -> NIC card software
  3. Install it on the server

Also, make sure you connect your ethernet cable when the server is off, then power the server on with the bootstrap zero-os image. Otherwise, it won’t find the proper NIC port.

Thanks for the answers. I will try the photo tutorial tomorrow and might perform a NIC update. I tried all of the 4 ethernet ports already.

1 Like

Ok good. Tell us how it goes.

A BIOS reset could work too.

Make sure you restart the node when you change port of the NIC. I restate just to be sure.

Some more info from Dell to help troubleshoot:

  1. One steady light shows the card is connected to the network.

  2. The flashing light means there is data transfer.


  1. Green light — A good connection exists between a 10-Mbps network and the computer.

  2. orange light — A good connection exists between a 100-Mbps network and the computer.

  3. Off (no light) — The computer is not detecting a physical connection to the network

But mik all my orange lights are 10g…

maybe the color code doesn’t work for all machines.
it’s written in the user’s manual of specific hardware.

Is it working with your 10gb? I know many farmers had trouble with NIC card with 10gb as oppose to 1gb NIC card.

It’s only allowing 1 gig links unfortunately, I’d bet if we’re missing the ixgbe drivers possibly?

Still works out though can they both pull a gig simultaneously though

Thanks I will check later.
How do I perform a bios Reset or a whole factory reset wit a poweredge r620. I was wondering this the whole time as I think there was something wrong from the beginning with the configuration.

It’s very simple:

Follow the first method: 1. Restore the BIOS defaults settings on a Dell PowerEdge Server.

Basically, there’s an icon : Default, when you are on the main page of System Setup.

Let me know how it goes!

Hey @helge

Just sharing some more ideas in case it can help.

Some farmers had problem with the NIC card and simply changed it for another NIC card and it solved the problem. It wasn’t the same error as you but I share it here in case it can be of any help.

Otherwise, making sure that the BIOS firmware and motherboard are up to date could help. Also making sure the date + time is up to date can help too.

Let us know how it goes :slight_smile:

Thanks for your effort.
Still not working.
I updated the bios and the idrac to the latest versions.
The nic doesnt even show up in the hardware overview. So i failed installing the latest firmware as the server says it cannot install a firmware for a device thats not exististing in the server. Thats strange because the network connection works perfectly fine, even using the intranet dell remote controller.
Tried to install nic drivers but that sid not work with the .exe file from the dell support page. Guess thats only for Windows OS, but as far as i am concerned they only provide the exe for the broadcom nic. Which OS do I actually have to choose?? :smiley:
Motherboard update might be a good idea, just need to figure out which morherboard i have :D.
Apart from that i think the only way is to exchange the nic. Whats a good and cheap nic for the r620?

1 Like

Yes I think changing the NIC could work, since you tried mostly everything else.

I’ll ask the telegram group for a cheap NIC for the R620, while farmers answer here too.

Id definitely say if you have done all that you may have a failed nic on your hand, luckily the gear is cheap second hand even to go to 10gb

couple decent options

but im a huge fan of the x540s if you have a open pci slot because they are compatible with nearly everything.


Amazing answer. Thanks.

as it has a Broadcom NIC inside im sure you need a diferent NIC. I have had these problems with my setup. if it was a broadcom it didnt work. since i put in a default Intel NIC everything is fine. 30 Bugs

You dont need to buy a Dell Part. Just a Intel PCI NIC

i mean it depends on, in which port you plugged it in:

Built in NICs:
Broadcom® 1GbE-BASE-T mit vier Ports (ohne TOE oder iSCSI-Offload)
Intel 1GbE-BASE-T mit vier Ports (ohne TOE oder iSCSI-Offload)
Intel 10GbE-BASE-T mit zwei Ports + zwei 1GbE (FCoE-fähig auf 10GbE-Ports)
Broadcom 10GbE-SFP mit zwei Ports + zwei 1GbE (TOE und iSCSI-Offload verfügbar auf 10GbE-Ports)

1 Like

Hey @helge

Was the problem solved with a different NIC card?

I hope so!

Hey Mik,

I think you can close this topic. As far as I know Helge finally got it running. I didn’t had my own hands on this maschine (we provided Helge this server) but the reason for the nic not beeing shown in BIOS respectively not beeing recognized by ZOS is because the firmwares of BIOS, iDRAC, Lifecycle-Controller and NIC were somehow incompatible to eachother. It was somekind of tricky to update the components… but after successfully doing so, the NIC finally shows up and ZOS booted correctly.

Some more background infos in case someone will have to face the same struggle when buying refurbished DELL R620: Depending on how outdated the installed firmware for BIOS, iDRAC and
lifecycle-controller is, updating those can be quite challenging. The most easy way for updating is surely by using iDRAC since BIOS and iDRAC itself can be updated here. But… sometimes this doesn’t work and the upgrading-prozess falls into some kind of loop. In this case I recommend to update BIOS as well as iDRAC (with lifecycle-controller) separately via live-linux. After this is done… it should be able to do a liveupdate (https to dell support webiste) via lifecycle-controller in order to update other components.

Here is a good video which describes the steps in detail:



It actually works now with the same card. As dany mentioned some tricky update procedure had to be done and finally with some luck it worked.
Thanks for oyur help