Let's test out FreeFlow Twin Beta (Formerly Uhuru)

FreeFlow Twin (formerly Uhuru) is a digital experience that presents alternatives to centralized social media, messenger, file storage, docs, web browser, and video conferencing.

Today, anybody can test FreeFlow Twin by visiting demo.freeflow.life and logging in with ThreeFold Connect.

This is an incredible proof of concept and should be exciting for anybody that’s involved in this project or seeking a decentralized future. Kudos to the team for what they have accomplished so far! Let’s get to testing so we can support the evolution of this experience!

If you’d like to offer some feedback (bug fix, feature suggestion), you can create an issue on GitHub. Use the title to describe the feedback and try to be as clear and specific as possible (screenshots appreciated) in the body field. Don’t worry about adding assignees, labels, projects, etc. The team will handle that. If you’re uncomfortable with GitHub, please leave your feedback here and someone will create the issue for you.

Let’s use the comments below for general conversation. Also, free to message me on FreeFlow Twin so we can test together. Just head to Whisper and add me as a contact: gosam.


Amazing release!

If I remember well, on the last Uhuru version release, I could do effective Kutana call with other TF users, but the Glass video streaming wasn’t up to point, on my side.

With this FreeFlow Twin beta, youtube videos work very well on Glass. It’s impressive!

Great work to the TF dev team and everyone involved in this.


After logging in I get:

{“statusCode”:400,“message”:“UnauthorizedException: no user id or derived seed found”,“error”:“Bad Request”}

Hmm, that’s strange. @Ken do you know what’s going on here?

We just received this report a bit earlier as well. It seems to be an error with specific phones, with other phones it works. We have managed to reproduce the error with a pixel 6 and are looking into resolving it for the next version now. Bad luck with none of the test phones used during testing phases having the bug. But that’s what community test feedback is so excellent for!


Got it, thanks @Ken! @aernoud were you trying to log in on mobile? Which phone model? Perhaps try desktop for now?

Also had the same error as @aernoud

Screen Shot 2022-08-18 at 10.25.51 AM

@gosam, this might be helpful: The phone is a Samsung Galaxy 7, Android 8.0.0 (Also connecting from a computer desktop with this phone + TF username doesn’t not work and get the same error message.)

Also, when logging, the letters are scrambled on one another.

Screen Shot 2022-08-18 at 10.26.07 AM

It does work well on a LG Q Stylo +, Android 8.1.0. (Both directly on the phone and through a desktop computer.)

Edit: @Ken, updating the Android 8.0.0 Samsung resolved the problem. Now it does connect. Didn’t even upgrade up to 8.0.1 but an in-between 8.0 and 8.1 and it works!

Hey @aernoud! You could try upgrading the software. Let us know if it works then. :slight_smile:

Which Software?

This error appears in my browser (after Authentication with the TF app).

I use the latest Safari on a M1 Mac mini with the latest version of the OS.

I couldn’t launch it on desktop nor phone before I updated the Android software of my phone.

So I meant, maybe it would work if you update your phone’s software, then try and log in on FreeFlow by authenticating with TF App with the updated phone.

I hope it’s clearer.

1 Like

For everyone who has helped us testing out freeflow at https://demo.freeflow.life/ thanks a lot for the reports. With your help we have tracked down an important issue and are working on getting a fix live as soon as possible.

The issue was that the first time you use freeflow, your environment needs to be started. If this first creation was being done on a phone, it failed. If the first creation was done on a desktop device, then later it will work on the phone.

We are now fixing this so the first deployments also work on mobile devices. We only found this issue due to all the community help, so thanks a lot!


It’s working fine for me so far.
Today I experienced another issue when having pending accounts.
When I click on the account I don’t get back without closing the whole site and logging in again…

I’m literally stuck on that screen, no matter what I click, I come back to it.