Error “ context deadline exceeded”

Good afternoon everyone. I’m currently getting lots of errors on my diy miner. Does any one k ow what these mean. Thanks in advance image

@scott - Can you please take a look at this?

Thanks Tully. It’s my first attempt but it was running fine ( I think ) for a few days.

I’ll give it a shot, but I’m sure someone more tech-savvy can answer more clearly.
This kind of errors come from the language Go, and I know vlang is based of Go. So it could help to troubleshoot.

These could be the cause:

Possible Causes:

  • Network Latency --> could be network, connectivity issue, did something change with your ISP or router/modem?
  • Firewall Rules / Cloud Security Rules --> did you add a Firewall that would block zero-os? Meaning you changed some parameters or else
  • Resource Contention --> could be a problem from exceeded CPU/memory usage
  • Slow I/O --> are you using external storage?

Was your miner properly running with zero-os then this happened. Or you tried to boot it and you got these messages?

I read on some forums and perhaps just rebooting your machine could work. It might also have to do with IPv6 settings needed some tweaking.

1 Like

Thanks for the comprehensive reply. I will try and answer.

  1. Nothing has changed with my router although sometimes it loses internet and then comes back a few minutes later.

  2. No firewall has been added.

  3. I only have 8gb of ram installed although I did try upgrading my ram to 16 gb a few days ago but this was unsuccessful so I went back to 8

  4. I’m using a 1tb Nv sdd and a 5 tv Hdd. This was ripped from an external drive but now is connected internally by Sata.

And I’m connected by a network cable so does ipv 6 matter?

Thank you.

Losing internet momentarily shouldn’t affect the 3node this way. Something else is implied.
4. is OK. It’s not external once you set it inside, ripped from the external box.
If you haven’t set anything with IPv6, it shouldn’t affect anything.

Maybe the system thinks it can work on 16gb but it’s now only with 8gb. This would explain the CPU/memory inconsistency.

Have you tried rebooting your 3node? Does the message still appear?

It looks like it’s having trouble connecting with the Threefold Twin and Grid.

I asked on the Telegram channel perhaps someone knows something that could help.

Yes I have rebooted several times. Thanks for all your help. Is there any way to check that it is still online and actually working?


Q: How can I know if my 3node is online on the Grid? Is there an Explorer for Grid v.3?

A: There are multiple answers to this.

(1) You can plug a monitor to your 3node and check directly its status.

(2) This link is the quickest online route to check your 3node status:

(3) Thanks to @scott, you can also use the Threefold Node Status Bot on Telegram (username: @tfnodestatusbot).

1 Like


Hi there!

So it seems your issue has happened before to others.

We will open an issue and the Threefold team will be looking into this.

1 Like

I’ve opened an issue:


Thanks so much. Greatly appreciated.

Despite all this my node is still reported as up which is obviously good. Will i still be mining though if it is having trouble connecting to the twin?

Thank you.

1 Like

I think yes. But some member could think otherwise. Usually when the 3node is shown in the explorer, all is good. Or Alles ist gut as the Germans say.