Trouble booting Zero-Os on my node with USB stick

For some reason, my Node will not read the USB stick during the booting process. It just bypasses the USB stick as if nothing is there and enters the BIOS - UEFI Bios Utility - Advanced Mode

Any ideas on how to troubleshoot this?

BIOS Srceen

The USB stick is the only item listed in the Boot Priority.

Please forgive me if this seems silly, but I’m assuming the ethernet cable should be plugged in while the node is booting. Maybe it makes no difference.

I changed the Network Stack to Enabled.

Should IPv4 PXE Support and IPv6 PXE Support also be set to Enabled? It is currently Disabled.

Secure Boot Keys are enabled. Should I clear Secure Boot Keys? Could this be the reason the USB Stick is not reading when the node is booting?

I would greatly appreciate whatever help I can get.

1 Like

Hi, welcome to our community!

I would recommend that you disable PXE and Security settings. Don’t enable things like “fastboot”!

ethernet should be plugged in, if not it cant download the ZeroOs via the script which is on the USB-key

If the EFI-Image doesn’t work try one of the others like USB-Image or EFI-File from the list Images. You can also try the ISO option, sometimes its the only option wich works. But if your BIOS is an UEFI the best way would be to use EFI-Image

Make sure that you enabled the option to boot legacy boot-devices on your bios if you try ISO or USB-Image

fi the BIOS doesnt find your usb-key try to choose the Start-device by your self with F8 or F12

i hope this will help, feel free to ask for further help


Indeed, secure boot is probably the problem here.

Selecting the usb as a temporary boot device via F12 or similar is okay for troubleshooting, but I’d prefer to know that it boots correctly automatically in case of power failure :slight_smile:

1 Like

Thanks for replying flowmotion. I tried everything you suggested spending a few hours trying every possible file type (EFI Image, EFI file, and USB). Nothing is working.

The computer will simply NOT read the files on the USB stick during the booting process. It’s weird. Once the computer enters the UEFI Bios Utility screen it shows that the boot priority is the USB stick. The computer simply will not read the data.

Perhaps this is a silly question, but does the computer need an operating system like Windows installed to read the USB stick? I followed the technical specs about how to build your own 3Node and there was no mention that you needed to have an operating system like Windows or Linux; therefore, I only got the parts (RAM, SSD card, Intel processor, etc.).

I thought this would be super easy. Unfortunately, it’s not.

Any more ideas?

Sorry that it doesn’t work for you…

You defenitely don’t need an OS installed. Bios/uefi should load the USB stick

May I ask you which motherboard, or server you have? Did you try different USB ports?

Sometimes servers behave a bit strange or have broken ports.

I have one server for example where only one port work.

Did you make the USB key with balenaetcher? With many tools it didn’t work for me but with this it worked.

Maybe try the USB key in some other computers like a laptop and try to boot up from it


I would suggest use the first option (EFI image). That should do the trink. Getting it on a stick can be tricky, but as @flowmotion said: belenaetcher is simple and works well ( and support many OS’s.

Also as he said try some different USB ports, one might be broken / not connected.

1 Like