Polkadot extension Firefox (Closed)

Somehow when I install the polkadot (js) extension on my laptop in Firefox, it installs it and shows active. But no where it pops up with a window to create an account like described. I’m pretty sure I’m missing something obvious but haven’t figured it out yet. Do i need something else activated as well?

You could try to delete the cache in your browser or try to open it with another browser (Chrome).

Additionally, you can follow guidelines here to identify any issues:

Hi @roest

Sherwin gave you good advice on this, but in case what you are missing is simply how to open up the extension, here is a screenshot from the Farming Guide Part 2:

Screen Shot 2022-06-14 at 4.49.36 PM

1 Like

Thank you both! I’m going to have a look at it again. But that icon (puzzle piece or anything else related to the extension) does not appear in my Firefox. It only appears in the list of active extensions. I was wondering if maybe JavaScript needs to run or so. I’ll check again tonight.


How to enable the Polkadot extension in Firefox


Open Firefox and write the following in the URL section:

about:addons

In the url:

Screen Shot 2022-06-15 at 11.04.01 AM

Then on the left side of the screen, click on

Extensions

Screen Shot 2022-06-15 at 11.06.23 AM
In the section Manage Your Extensions, there are two categories Enabled and Disabled. Perhaps the Polkadot extension is disabled.
To enable it, click on the button left to the three dots (see picture below, the green circle).
Screen Shot 2022-06-15 at 11.07.35 AM

You should then be able to see the Polkadot extension in the Enabled category:

Screen Shot 2022-06-15 at 11.09.20 AM

Then you should be able to see the extension on the top right corner of your screen (green circle):

Screen Shot 2022-06-15 at 11.10.16 AM

Once you click on the button, you should be able to see the Polkadot extension screen and then proceed with the rest of the steps written in the Farming Guide Part 1.

Screen Shot 2022-06-15 at 11.11.06 AM


How to enable the Polkadot extension in Brave


Open Firefox and write the following in the URL section:

brave://extensions/

In the url:

Screen Shot 2022-06-15 at 11.16.07 AM

In the section Extensions, find the Polkadot extension and click on the button designed by the green circle in the next picture:

Screen Shot 2022-06-15 at 11.16.22 AM

Now, when you click on the Extensions button at the top right of the browser’s screen, you will be able to see the Polkadot extension.

Screen Shot 2022-06-15 at 11.20.54 AM

If you click on the encircled button below, the Polkadot extension will be easily clickable on the browser’s main window:

Screen Shot 2022-06-15 at 11.21.56 AM

The Polkadot extension can now be easily opened:

Screen Shot 2022-06-15 at 11.22.22 AM Screen Shot 2022-06-15 at 11.23.47 AM

Thanks for all the hard work. But whatever i try, the icon does bot appear in the browser despite the extension showing active. I deleted, cleared cache and history, reinstalled, all looks fine, but no icon anywhere

1 Like

I reinstalled (refreshed) Firefox, now it worked. Weird. Thanks again!

1 Like

Alright! Problem solved then. Thanks for the feedback, I added this information on the related Q+A.