Node Deletion Failed (CLOSED)

since resolving my issue from issue How do we troubleshoot missing resources (CLOSED) I had to ultimately rewipe my harddrives and when I restarted my node I was assigned a NEW node ID. now my previous node ID is showing as down and when I try to delete it I follow the steps and the request is submitted to the chain but then a response occurs that node deletion failed. who should I advise about this? how should I correct this or do I just ignore it?

1 Like

I had this same issue and asked for help in the Telegram support chat, I’m gonna copy paste the response I got there that helped me:

"If it doesn’t work with the portal, I think you could do it with Polkadot.js UI, going with mainnet this link used to work:

Head to the extrinsics section, select the account that owns the farm, choose tfgridModule from the first drop down, then deleteNode or updateNode.
Not 100% sure it works that way with nodes, but it works to update/delete farms.

But that being said, it doesn’t matter if you have nodes unused that are on the TF Grid. It won’t hinder anything. So you could leave it there."


Hi @amishtech. Good effort in the last 2 stories I read. You are developing these server skills rapidly. For you (and for others I hope) there is a command line tool available that allows you to add/delete/inspect farms and 3nodes on the TFChain.

This provides you with a simple interface to manipulate chain items.


thanks for sharing this by following the steps I was able to get to the point of deletion of the farm node but noticed that in order to send the transaction to be processed there is a fee of Fees of 1.0111 milli TFT will be applied to the submission. I dont have any earned TFT in my account as i am too new and this makes even more sense now why I was getting a error as it may have tried to pull TFT when none was there and errored out and would not delete. I continued to submit the transaction but think I missed a step or did it wrong. under “id: u32” section there was a 0 I replaced the zero with the node ID was trying to delete 3316. I thought that was needed to know which node to delete. but again that did not work again maybe due to not enough balance to pull from but no error was populated so I have no clue

thanks for sharing not sure I understand these links i am not a coder and there is not enough info to guide me on how to use the information in either of the 2 links. any assistance would be nice still learning all of this is like a new language to me but slowly understanding the basics. would love to learn more especially regarding polkadot seems like this is the core.

@amishtech. You are right, there is a cost to deploying on the grid and there is a cost for executing (start/stop) smart contracts. But, contract dissolve when you have no more balance in the wallet, so in the end, everything will self delete.

Hi @amishtech

So just to recap: you can delete a node via the, but that being said, the steps given by @proletariat can be more effective. But, it costs some TFT to proceed. All that being said, I want to make it clear that:

it’s OK if you have an unused node ID on your farm.

It doesn’t matter at all. It won’t take resources or anything. So you can simply let it as is, and when you get some TFT you can delete it if you want, it will cost a fraction of a TFT I would say. But it’s not necessary to delete it.

Hope that helps!

I would also stipulate that if deleting a node whether via ( or the steps given by @proletariat it will cost 1.0111 milli TFT. the only other issue I see is that the should have this same text info presented when trying to delete a node otherwise they would get the error that I received. Technically the error should be changed to “Not enough TFT to process request”

1 Like

Hi @amishtech

I think you’re suggestion is interesting but I’d like to know what the TF team+devs think about this.

My point is, some people had trouble with the Portal to delete a node, but then it worked with Polkadot.js UI. So maybe it’s not always because there is a lack of TFT fund.

@weynandkuijpers and @scott, what do you think?

Once we get this figured out, we could close the post as it’s been mostly answered.

Hey guys,

So it turned out that the initial link shared was for dev net.

here is the correct link (for main net!):

So for the record, here are the instructions to delete a node or a farm on Polkadot.js / Portal TF Grid:

Can I change the name of my farm on polkadot.js? / How can I delete a farm on polkadot.js?

It’s possible to delete and rename farms through the Polkadot UI. Head to the extrinsics section, select the account that owns the farm, choose tfgridModule from the first drop down, then deleteFarm or updateFarm.

For mainnet use this link.

I try to delete a node on the TF Portal, but it doesn’t work. Is there any other way to proceed that could work?

It’s possible to delete nodes through the Polkadot UI. Head to the extrinsics section, select the account that owns the farm, choose tfgridModule from the first drop down, then deleteNode. For mainnet, use this link.

Since this post has been answered, it will be marked as CLOSED.

Happy Threefolding!

1 Like

Generally, when using the Portal this should not be a problem because when you activate your account there it is funded with a small amount of TFT. That should be enough to cover the gas fee required to delete a node. I suppose a user could transfer all the TFT out of their wallet and run into an issue… so I tested that case and see this error:


This all seems okay to me. But I’m still wondering about the error you were originally seeing in the portal regarding node deletion failed. Maybe there’s some other issue with the portal?

Yep, my mistake there… thanks for chiming in here and clearing that up :slight_smile:

No problem Scott. You definitely helped us a great deal for this issue anyway.

We all should have seen the word DEV in the url!! (…).

Nothing can stop Threefold and the New Internet!

I can’t seem to find any delete button on… Has it been removed by now? If I remember correctly it used to be next to the globe icon under “actions” in the node list view. (using Firefox)

I also tried following the steps in this post by going to

Here however when I select my account it shows zero free balance so I can’t submit the deletion. On my account shows the balance I have. What do I need to do to get some of that balance available for the node deletion?

The URL you have here has .dev.grid in it, you want to be on main net.

Try this one:
And let us know. If it still doesn’t work, we’ll troubleshoot and fix the issue.

As it’s written in the discussion: it’s OK if you have an unused node ID on your farm. It doesn’t matter at all. It won’t take any resource or anything.

Wow, can’t believe I didn’t notice that. Sorry! Thank you for the quick reply @Mik

Also just to clarify. Are we supposed to select deleteNode(id) or is it deleteNodeFarm(nodeId)"

I know it’s not strictly necessary, I just need to clean up a bit so I don’t have all these non existent nodes distracting me from nodes that are actually down.

After trying, deleteNode(id) didn’t work for me. (according to a different post “this is a function that can only be called by the node itself”)

deleteNodeFarm(nodeId) did work to delete a few of my older nodes, but for some of the newer node IDs, I get an error saying the node doesn’t exist.

So I was able to delete 3 nodes but I still have 6 that I can’t get rid of. Any Ideas on what could be causing that?

Here’s a screenshot:

Screenshot from 2022-12-17 22-54-55

Yes, the function deleteNodeFarm(nodeId) should be used and not deleteNode(Id).

OK good to know deletenodeFarm(nodeId) still works… in most cases.

I’ve heard too that this function worked but not all the time.
Last time what was said is that this issue does happen but this should be fixed in a later grid release.

I think there is an issue raised on github. I’ll write one just in case.

Potential momentary fix: wait some time, then try later, maybe something on the grid isn’t yet up to date.


Latest news: this will be fixed soon in an upcoming release.

Thanks @Mik. I appreciate the follow up. Looking forward to the fix.

1 Like