No disk: registration failed (DELL T3500)


I have the DELL T3500 workstation and wantt o use it as DIY TF node. My spec:

  • 24GB RAM
  • 256GB SSD
  • 1000GB HDD

After reading all guide, and check all similar problem. I still cannot start the node and always get the message No disk: registration failed

Have tried:

  • Disble RAID and use ACHI or ATA
  • Wiped the disk and leave raw format

Is there any other way i can try to start the node?

Is the SSD visible in bios? Did you wipe it?

Yes. SSD visibe in bios, already using an Ubuntu USB OS to wipe all the SSD

Perhaps the 500gb min SSD size is being enforced now.

I’ve booted a node recently with only a 128gb SSD. Now that SSD is a factor in calculating CUs I don’t think there’s any reason to enforce a minimum.

Just to confirm, you used the wipefs command to clear the disk? If so, do you see any errors during boot? After the node boots, can you switch to the logs screen by hitting alt-f2 and also look for any errors there?

is this the boot log?


so i don’t see any error during the boot.
but still disk registered

Hey @tan

If you got “time”, you can try badblocks command on the two disk:

sudo badblocks -svw -b 512 -t 0x00 /dev/sda

if the disk is sda for example.

This command checks every byte in the disk and turns it into a zero. So it’s long but very effective.

It worked at least a couple of times for farmers who had strange results with wipefs.

Let us know if it helps!

1 Like

It doesn’t help. I have ran the command badblocks for both SSD and HDD, but after boot with ZeroOS, it still the same.

DELL T3500 does not allow to disable RAID, only choose autodetect / ATA or AHCI, i think this is the problem caused ZeroOS cannot recognize the SSD


Have you put each disk in its own RAID0?

Yes, each disk in different RAID. Not work

Did you wipe it with wipefs? What model SSD is it?

wiped it, also using badblocks command as previous suggestion.

I even tried two different ssd, but still no ssd disk. I think the problem is from Dell T3500. This machine cannot run TF farm.

Hello Bronzer
Tell me at the end of the installation does this screen appear?IMG-20220808-WA0000

Yes. I have this screen

Bypass the raid card, I think you can get this to work.

how to bypass the raid card?

Checking docs for the T3500, it looks like you have an optical drive connection. Normally these are connected directly, not through the RAID controller. I’d recommend using that to connect the SSD. Then you can at least confirm the SSD is properly prepped and get the system online, then see if the HDD is in fact detected in the current config.

I would expect AHCI mode to work fine, but we haven’t seen this system before so compatible bios settings are unknown.