No disk: registration failed (CLOSED)


i have a dell r620 server and have 2 ssd 2.5 (1x 4TB, 1x 1TB9.
Unfortunately it tells me that the ssd was not recognized.

I tried everything on
No ssd detected. can i use an m2 ssd and How to clear disks for DIY 3Nodes?

I cleaned the ssd with windows.

  1. diskpart
  2. selected the ssd
  3. hit clean


Does anyone have another idea?

1 Like

I have the exact same server and have the exact same issue. Was trying to set mine up I have 1 SSD 1tb and 9 600 hdd. I wiped them all killed raid reset raid 0 for each type of drive but nada. Not sure either how to set them up

1 Like

Hi @fd

I’ll give you some information and perhaps this can help you.

First can you tell me how do you plug your SSD disks in your R620?

You might need to re-flash your RAID card if you are using it. Here’s a good link. And @FLnelson’s video on how to re-flash the RAID card.
You might need to check the connections of your SSD disks. Also make sure you can see all the disks when you go into your BIOS.

Also, as @scott said,

A note if you’re having trouble getting your disks recognized by Zos: some farmers have had success enabling AHCI mode for SATA in their BIOS

I’ll give some steps to wipe disks with a Linux distribution. Maybe it will help.

4. Wipe All the Disks

  1. Create a Linux Bootstrap Image
  2. Boot Linux in Try Mode
  3. Wipe All the Disks

Threefold runs its own OS, which is Zero-OS. You thus need to start with completely wiped disks. Note that ALL disks must be wiped. Otherwise, Zero-OS won’t boot.

An easy method is to simply download a Linux distribution and wipe the disk with the proper command line in the Terminal.

We will show how to do this with Ubuntu 20.04. LTS. This distribution is easy to use and it is thus a good introduction for Linux, in case you haven’t yet explored this great operating system.

1. Create a Linux Bootstrap Image

Download the Ubuntu 20.04 ISO file here and burn the ISO image on a USB key. Make sure you have enough space on your USB key. You can also use other Linux Distro such as GRML, if you want a ligther ISO image.

BalenaEtcher is recommended as it formats your USB in the process, and it is available for MAC, Windows and Linux.

2. Boot Linux in Try Mode

When you boot the Linux ISO image, make sure to choose Try Mode. Otherwise, it will install Linux on your computer. You do not want this.

3. Use wipefs to wipe all disks

Once Linux is booted, go into the terminal and write the following command lines.

First, you can check the available disks by writing in a terminal or in a shell:


If you want to wipe one specific disk, here we use sda as an example, write this command:

sudo wipefs /dev/sda

And replace the “a” by the letter of your disk, as shown when you did lsblk.

To wipe all the disks in your 3node, write the command:

sudo for i in /dev/sd*; do wipefs -a $i; done

Make sure you have no important data on your disks, or make sure you have copies of your disks before doing this operation, if needed. The term sudo gives you the correct permission to do this.

Once the disks are wiped, you can shutdown your 3node and remove the Linux Bootstrap Image (USB key). Usually, there will be a message to tell you when to do so.

1 Like
  1. Download GParted Linux distribution ISO image.
  2. Create bootable USB disc using Rufus.
  3. Boot it and start in command line mode (you can choose graphic mode but some graphic cards are not supported).
  4. Type “sudo fdisk -l” to see all available disk drives. Usually they are showed as /dev/sda or /dev/sdb etc.
  5. Type “sudo wipefs -a /dev/sda” to clear disk sda for example.
  6. Type “logout” to exit the system.
  7. Turn off the computer and plug Zero-OS USB flash card.

Voici un nouveau systeme propre !

1 Like

For me All my disk are connected via the front ports the SSD is recognized as SATA and my other 9ndrives are recognized as SAS

Did you get your 3node to boot properly?

Yes but it has the no disk error and registration failed and no ssd disks detected


I setup the drives as raid 0 via the dell raid management thought that’s what was needed. I’m not a big server person

1 Like

If you are using the onboard storage (front panel disks), you surely need to re-flash (or by-pass the RAID card).

Here’s a good summary on this:

You can use the on board storage on a server without RAID. You can re-flash the RAID card, turn on HBA/non-RAID mode, or install a different card. No need for RAID." @FLnelson It’s usually easy to set servers such as a HP Proliant with the HBA mode. For Dell servers, you can either cross-flash the RAID controller with an “IT-mode-Firmware” (see this video) or get a DELL H310-controller (which has the non-RAID option). Otherwise, you can install a NVME SSD with a PCIe adaptor.

Wow okay hopefully not to hard

1 Like

Thank you for the answers. I also have the ssd on the front panel.
I can disable the raid controller, so I don’t need to flash the raid controller, do I?


Both ssd are showing as physical disk on bios.

1 Like

If it works by simply disabling the raid controller, that’s OK.

But otherwise, you’ll have to check the steps written above.

What is the model of your RAID controller?

I think h710 mini as shown on the second image.

Oh well I should have seen this! Thanks.

So yes I think with the H710 you will be able to easily crossflash the RAID controller with the links above (Nelson’s video + Fohdeesha docs).

If you don’t want to get into these steps, which aren’t really hard anyway, you can get a Dell H310 controller, in this case the non-RAID option will work without any crossflashing.

Let us know how it goes @fd and @amishtech

We’re here to help if you meet any difficulties.

Then it should boot fine.

1 Like

I just finish cross flashing and the os just finished booting all green woo hoo! 16530723383416798941480611148796

1 Like

Thanks @Mik for your quick response and help… On a side note I also have the h710p

1 Like

Alright! That’s it!

Happy Farming!!

Thanks for the feedback. It’s always a pleasure to help TFarmers building the New Internet!

It worked for me, too. Thank you very much for all the info.
A small hint for all: You must turn on the raid controller in the bios otherwise freeDos does not show you the raid controller with the command Info.


Good to know it worked for both of you @fd and @amishtech

The Threefold Grid is growing stronger thanks to you guys!

I will add CLOSED to the post title so people will know the problem has been fixed.

If you have other questions unrelated, we can do another post so it will be easier to search by the Threefold Community.

Happy Farming and … Let’s New Internet!

1 Like