Migration to V2 issues

Issues farmers are facing while migrating to V2

I have migrated finally to V2, but not without issues unfortunately, and 1 of my 4 servers still is unable to register…
First thing you need to do is create yourself a 3-bot from jumpscale code, so through a Command Line Interface, but that only works from a Mac or Linux (Ubuntu) environment, and as I don’t have either, I decided to spin up an Ubunto VM on Vultr, which you can dispose when you are done, quite easy…
But when trying to install Jumpscale, I ran into a blocking issue, the error was that the code could not find a Network interface card named “eth*”. So the installation code is specifically looking for a NIC named eth0 for example, but cannot find it.
Since Ubuntu 17 however, netplan is used and the NIC is sometimes renamed to ens3 or ens33 for example, breaking the installation script.
I am FAR from a Linux expert, so I found this after substantial search and trial & error, but what you actually need to do is change the name of the nic in Ubuntu 18.04 to eth0 for example, and then the installation of jumpscale works…
This is how I changed the NIC name from ens3 to eth0:
ifconfig ens3 down
ip link set ens3 name eth0
ifconfig eth0 up

Once jumpscale is running, you need to set up the 3-bot using the document from wiki (https://wiki.grid.tf/#/tf_farming/v2_jsx_farmsetup), and that worked without issue. But when registering the farm I ran into another error, namely the farm.threebot_id = j.tools.threebot.me.default.tid step.
j.tools.threebot.me.default.tid has the value 0, don’t know why…
After creating my 3-bot, I saw the number was 94, so I changed that line to be j.tools.threebot.me.default.tid = 94, and that worked.
When the farm was created, it showed up on the gridexplorer, and the code showed me a farm ID of 161,434
That ID is what is needed to generate the boot files from the hub but be aware that the number you need to fill in the hub form is 161434 WITHOUT the comma, it is an integer!
You will have another number of course, but feel free to use mine, I will gladly take your farmed TFT’s :slight_smile:
After weeding through all that 3 of my 4 nodes got up and running, but 1 server still get’s stuck while initializing and it is a similar problem as the one I had on V1, where the machines registered with wrong server data (disk space etc…)
I hope that issue will get resolved as well since I will most probably not be the only one having this issue looking forward…
Cheers!

Hi, thanks for the feedback :slight_smile:

Thanks to your remark we have fixed the bug you identified and also made the documentation about the farmer ID more clear. The boostrap service where you generate your 0-OS image should also prevent using a wrongly formatted farmer ID from now on. So for all that, thank you.

Now let’s get your last node registered.
Can you share any error message or screenshot about the faulty node ?

Also regarding your disk type detection. Are all your 4 node have the exact same configuration ?

Zaibon,
Yes all servers are Dell and configured likewise. The server that will not start up just halts halfway and gets stuck. This is what shows on the screen. F3 does not show console:


Nothing happens after this…
the node has different size SSD as the other servers, but the setup is the same.
It used to register fine a few weeks ago, then it started showing up on V1 with completely wrong disk data

Hey @TFFarmer ,
is there a way I could get to the console of that server ? (Like: it has IPMI )

1 Like

Jan,
That sounds an awful lot like Chinese to me :slight_smile:

1 Like

Problem solved, it was a setting in the virtual disk thing stuff in the server settings… Now running like a charm! Thanks for the support Jan!

2 Likes

my absolute pleasure :wink:

1 Like

Hello! what setting did you change? i think i run into the same issue…
i have tried everything :smiley:

in case of the IBM Servers the disks are mounted… in case of Dell i cant say… but if i disable all disks of the DELL Server the ZeroOS is booting and gets toi the same Screen like the IBM-Server

Get Stuck at:

DELL Servers:

IBM Servers:

Harddisks are mounted:

Same issue today, and it turned out to be the raid controller … Kaput!
But what if you hit alt F3, you don’t see the console?
Did you create virtual disks in the raid controller?

Hi!

the last screenshot ist the output of the command “df” i run in the console.

also ping6 to ipv6.google.com is workling.

all 3 disk are jbod(s) nonm virtual… and they are mounted…

on the DELL Servers there i can only create virtual disks and there it doesnt boot anyway…

i spoke to christophe - he said i should create a github issue. i will write the link here

i opened it: https://github.com/threefoldtech/zos/issues/616

1 Like

I have either made a mistake or there is another problem need a bit of help
JSX> farm.threebot_id = j.tools.threebot.me.default.tid = 118
shows all the correct data

when i try to register the farm using
JSX> explorer.actors_all.farms.register(farm)
all i get is

‘GedisClientActors’ object has no attribute ‘farms’

if i list then there is no farms
JSX> explorer.actors_all

gedisclientactors GedisClientActors

properties:

  • alerta : <1d43a9bb6fb4c88ed3de82ba560afdba.GedisClientGenerated object at 0x7f1b8bd24b70>
  • chatbot : <c4604db1fbe445c2740dddb647efe3e0.GedisClientGenerated object at 0x7f1b8bc6ac88>
  • explorer_proxy : <8b0e6c40b739fe8525ce29a80e3836b6.GedisClientGenerated object at 0x7f1b8bd10e80>
  • gateway : <fd9227822c9c63a81ab01013a612c846.GedisClientGenerated object at 0x7f1b85bf8940>
  • gridnetwork : <775e5a0d2613e1b29edbc3801c3e0001.GedisClientGenerated object at 0x7f1b85b38eb8>
  • identity : <7b4245d572a7f4f3fd5e033487002fdb.GedisClientGenerated object at 0x7f1b8bc6a160>
  • myjobs : <bed901d83fda1aa8a8de6bb88da59a83.GedisClientGenerated object at 0x7f1b8bd28f28>
  • namemanager : <1b240efe9b67268d2a6f8305cc4bfdbc.GedisClientGenerated object at 0x7f1b85bf6fd0>
  • package_manager : <743f9bc3c097f8a66c0a99ae33e9a0cf.GedisClientGenerated object at 0x7f1b8bf74f98>
  • provisioning : <bb002de41e529692843de6af8a9aa4be.GedisClientGenerated object at 0x7f1b8bf0ac50>
  • system : <edf950096d7bb38243fa9b1f070ed2f2.GedisClientGenerated object at 0x7f1b8bcf6240>
  • wiki : <8c74cd643d93ced3c789e7f3004399cc.GedisClientGenerated object at 0x7f1b8bc6a128>
  • wiki_content : <f97575863b107b8b296da8f74c0f3b8a.GedisClientGenerated object at 0x7f1b8bc36e48>
  • wiki_gdrive_manager : <df1de2a504d2a0898b77cba6563c49c9.GedisClientGenerated object at 0x7f1b8bc36358>
  • wiki_team_manager : <2a349c2acf9c34ee125d327905738325.GedisClientGenerated object at 0x7f1b8bc36908>

Hi @brautech2020.

There has been an glitch in our wiki during some maintenance last week. And old version of the migration documentation was published by mistake. The reason you have these error are because you use the outdated documentation. This problem has been fixed in the mean time and the up to date documentation is live at: https://wiki.threefold.io/#/grid/tf_farming/v2_jsx_farmsetup

Sorry for the inconvenience

1 Like

Thank you Kindly
The ```
farm_id = explorer.farms.register(farm)
works

1 Like