Issues with booting into Zero OS

Hi all,

Have a R620 that I’m trying to boot off a USB via bootstrap image but I cannot get past the “initializing networking devices…” aspect. I’ve run this off a VM without issue, as well as 2 other machines at home and this R620 that I’m using is the only one I’m having issues with. I’ve tried all of the different options, creating a bootable CD/DVD to no avail unfortunately. Here’s a screenshot of the console after trying different options. Screenshot 2022-02-08 153643

Any help would be appreciated! Really stoked about this project but am kinda stuck at this point

1 Like

This looks like pre-zeroOS boot. Try a usb with the EFI image with the BIOS set to UEFI boot, then try the “dd” usb image with the bios set to sata or bios boot.

With the CD you tried, did you burn the correct image on it? What boot method was the bios set to?

I haven’t failed yet on getting a server to boot zeroOS, you will find the correct combo of boot media and settings.


Indeed, I also believe this is a BIOS boot method issue. Please have a good look at the BIOS setting (priority, secure boot yes/no, device etc) and use the EFI image (first/top option @

For more information:

Looking forward to welcome the R620


Thanks for the insight, I will try all the methods again. The ““initializing networking devices…” portion happens after it’s booted off the USB, so it’s able to boot off the USB but cannot get past the first part of the Zero OS. I did the EFI image with BIOS set to UEFI boot, as well as using UEFI boot selection when prompted (just to rule out order of operations) and I get the same result. I’m unable to get the BIOS boot to see the USB drive under the HARDDRIVE options, as I only see normal boot, optical drive, & network boot. I’ll try again with some other methods and see if I have any better luck.

I burned the CD right from windows and macOS (only had 2 laying around the house) and will try again later today to see if I can get it to work. My only thought is there’s something on the R620 that’s blocking it, and since I’m only going to use this as a part of threefold I was going to system reset the server to see if that helps next.

I have another R620 to try this on, but that’s running a lot of my homelab VMs atm.

Thanks all for the help!

UEFI boot from CD didn’t work HOWEVER, BIOS boot from CD DID work, so now we’re up and running. Thanks! I knew it was some combo that would get it going

1 Like

That’s great.

I have a R720 and I too couldn’t boot until I did CD/DVD BIOS.

I’ll do a synthesis of your question and the answer and put it in the FAQ.

Hey hey - welcome! :champagne:

I got the USB Pen in BIOS mode working, however, once i created the RAID0 for the HDDs, it starts booting ZeroOS, and then seems to stop booting and just gives a blank screen, anyone saw this on a Dell R720?