How to set-up your own 3Node

Zero OS is designed to be very efficient and secure. To fully achieve that, it needs to be running on bare metal. Adding an extra virtualization layer below Zos runs counter the core idea of the ThreeFold Grid: to provide a base capacity layer with better security than Linux servers and minimal overhead.

2 Likes

Hi guys,

I have followed Alex’s DIY node build guild and I’m all setup and running, eveything looks good locally and my node is showing in my farm online so I think its all setup correctly.

What I would like to know is what should I be doing to optimise or change on my rig?
Currently I built this as just POC to see if I could achieve a DIY node, the hardware I have is
i7 CPU
16gb ram
1x 500gb SSD

also, is there anyway to see what contirbution my node is making to the network or validate this its working as required?

I’m thinking of using another rig and building my second node, any suggestions on hardware to put in it?

lastely, please can somebody explain these KPI’s. what they are and if I should see any feedback/usage

image

thanks all and good luck with your builds

Rusty

1 Like

Thank you for the explanation. I managed to follow the steps from 1-4 but I got stuck at step 5 please see the below picture. I would be grateful for any advice how to solve this issue.IMG_20210622_101305

do you have a DHCP service running on your network?

1 Like

Hi Rusty, I have a IPv4 DHCP service running. thank you for pointing it out. it is solved now!

2 Likes

you’re welcome, glad its up and running.
Let me know how you get on…I’m new to this and courious to know about what hardware to be using.
I’m currently using an i7, 16gb ram, 500gb SSD. Wondering if this is decent enough to be part of the network?

Hi from Canada!

Thanks @alex24 for these great instructions. It did work alright (with Balena Etcher at step 4 and a simple “Reset this PC + removing files” via Windows 10 for the step 1 part “erase a disk”)! Up and running now with my i7, 4 core, 32GB RAM, 1TB SSD refurbished HP EliteDesk.

I’m trying this low(er) cost +/- same specs as the Titan 3node (without the super nVME of the v2.1…!). I will be able to report the difference. It will be interesting to gather farmers’ harvests data and compare efficiency of set ups. I read somewhere else in the forum that this is an ongoing project. It’s great. Looking forward to expand that farm.

Funny anecdote, while I was doing the 5 steps, I thought step 5 was not working so I removed rapidly the USB key in the process of the Zero-OS being loaded, and thanks to the stateless OS (from what I understand), the removal of the USB key during the process did not stop the booting to be done properly! That would never have happened if I was installing Windows or Linux as I understand. I guess it was there long enough to connect with the blockchain and then complete the installation online.

Powerful lightweight Zero-OS!

Thanks again for this great post and the overall forum. I read it for days before jumping into the installation and it all worked well. I get +/- the same kind of Zero-OS screen as @wasiek with 1% CPU usage and 1% Memory usage (the CPU sometimes oscillates shortly between 0 and 2%).

Let’s see, as @scott proposed, how many tokens the node has farmed at the beginning of next month!

If not now, then when? Let’s build a new internet together. :slight_smile:
Thanks.

2 Likes

PXL_20210626_204144729

I was able to follow the guide, but I am stuck on the above screen. It stayed like that six hours then I treat the computer and it’s showing the same screen. Any thoughts

Hi Scott,
I 've managed to get my DIY 3node up and running but I think there is something wrong with my setup.
My node has 2 SATA SSDs 240GB each and 1 SATA HD 1TB, but my 3dbot dashboard admin page shows that I have only 223GB total space
Also my node has only 8GB RAM but the dashboard shows that I have 16GB Total
I suppose Volumes in status fo the Zero-OS does not represent my total Disks does it? because it shows 0 volumes as explorer page also shows.
Also for some reason, it says I’m in ITALY but my node is in GREECE.
How can I correct these?
Thanks!
Screenshot 2021-06-29 at 14.29.19

Just realized that this never posted when I originally wrote it… hope it’s still relevant

Yep, indeed you are part of the network already :slightly_smiling_face:

One thing to understand about the Grid is that workloads are deployed by developers or IT admins to specific nodes, based on their own requirements. That may include geographic location, node specs, and the availability of multiple nodes in one farm. Whether or not your node would be chosen is just a matter of waiting and seeing.

The good news is that you’ll farm tokens either way. Personally, I’ve taken it upon myself to see that my node gets utilized, by deploying workloads that are interesting, useful, or even generate some profit.

Your node’s specs are just fine, although adding some RAM would increase the number of tokens you will farm. If you want to see some examples of other nodes, including mine, check out the farming setup thread.

1 Like

Hey @StormLord, nice work getting your node set up!

This is a common confusion :upside_down_face: That dashboard shows the specs of the node or computer your 3Bot is running on, rather than your farm. You can go to the farm management to see what resources your node is making available to the grid, or check it on the Grid Explorer.

Glad to hear of your success @idrnd!

We’d love to have a post about your node over in this thread: Let’s share our farming setup

To clarify about the USB stick, it’s only needed for Zero OS to do it’s initial bootstrap and download the core operating system. However, I recommend you leave it connected for any updates or reboots that happen in the future. There’s actually not a blockchain involved in this step: the OS is downloaded from centralized TF servers at this point, as far as I know. Decentralizing these parts of the process is definitely an important step for the network, in my opinion, so I hope we’ll see some kind of system to replicate Zos across the Grid in order to create extra resilience.

Indeed, we are building it, and the time is now :smiley:

1 Like

My best guess is that there’s a firmware issue with your network adapter that makes it incompatible with Zos (separate drivers than the bootloader that gets you to this point). You could try another NIC if you have one, and/or head to the Zos Telegram group to ask for support: https://t.me/zero_os_tech

Quick update: Long story short, I wasn’t sure if the SSD was properly set to having only zeroes and I realized that the Windows OS was still on the SSD. I had trouble with this line of code:

A : for i in /dev/sda; do parted -s $i mklabel msdos; dd if=/dev/zero of=$i bs=1M ; done

At first, as I said earlier, I simply did a reset on the Windows OS. Zero-0s seemed OK with 1% CPU usage and 1% memory usage but it seemed stuck at those numbers. (All the rest was zeroes.) When I rebooted the PC I could see that the Windows OS was still present on the SSD. So I dug online and found some nice lines that I will share in hope that it might help anyone at some point! (Sorry for the long post!)

To see if there were no more partitions, filesystems and labels, I used these throughout troubleshooting:

sudo fdisk -l
sudo fdisk -lf
sudo parted -l
sudo parted /dev/sda 'print’
lsblk --f
lsblk --raw

To read and (over)write zeroes (0x00) everywhere on the SSD, I used this:

B : sudo badblocks -svw -b 512 -t 0x00 /dev/sda

where 512 is the block size (without -b BLOCKSIZE, it will simply go slower).
0x00 represents the zero byte. Warning: line B is destructive. It erases the disk.

https://wiki.archlinux.org/title/Badblocks for more info on that.

I had read that this previous line (B) was great for pre-deployment. Since the line (A) did not work on my end, that’s what I used.

Then to double check if the SSD was indeed only composed of zeroes, I used:

cmp /dev/sda /dev/zero

where sda is the SSD in question and /dev/zero is a typical file with only 0x00 (zeroes). This line compares the two and confirm if it’s only zeroes.

To confirm there was only zeroes, the result should be:
cmp: EOF on /dev/sda

I also used that command:
sudo pv /dev/sda | od | head

As another test to see if there was only zeroes on the SSD.

Then when all seemed ok (no label, no partition, no filesystem, all zeroes), I rebooted the computer and then put the Zero-0s usb key. Now it shows that the farm is up and running and I get 1-2% in the CPU usage and still 1% in the memory usage. I will share with you guys if anything else comes up and will be able to put updates with the monthly report from Threefold sent by email.

PS: I did use Ubuntu 20.04 linux distro in the Try Ubuntu mode to boot outside of the SSD.

Question: now I wonder about the other parameters in System Load on the Zero-0s screen. Containers and all the others except CPU usage and Memory usage are set to 0. Does it mean something’s wrong?

That’s it. I hope this might help anyone with his/her own troubleshooting. :slightly_smiling_face:

EDIT: there was a " - " missing in the line of code named B. ( B : sudo badblocks -svw -b 512 -t 0x00 /dev/sda)

I tried to see what resources my node is sharing via Grid Explorer but I could not find anything useful more that it is UP and running. How can I find that the resources that my node has are correctly identified and shared on the network?.
Also the Grid Explorer is mention as my location in ITALY but my node is in GREECE, can that be changed somehow?
Screenshot 2021-06-30 at 13.06.43

Can anyone point me on a place to watch where my farm is generating earnings? Is there anywhere to see how much TFT has been raised by the farm? Is the payout monthly? Any information appreciated thank you

as I understand, there is no way to see earnings because they are calculated at the end of the month.
They tell that you will receive a mail with your status and earnings.
I’m also new to this, so at this month I don’t believe will be any kind of earnings as I understand that you must have 98-99% uptime on every month to earn tokens.

I was able to get it to show but had to go to Packages first and then install Farm Management

Go to Packages and install Farm Management

That is exactly what I am seeing…Not Configured…I’m sure I forgot a step somewhere. Are we supposed to configure something in our router? Or do we need to manually add the farm under Farm Management? Please, any help would be greatly appreciated. Thanks guys!PXL_20210701_051739858