Getting my hands dirty with TFGrid v3

Hi everyone,

Just wanted to make a quick post to share the result of my first hacking session on the GridV3.

Like I shared in another post, I wanted to try out the v3 to start running a bunch of substrate base blockchaine nodes on the grid. To have an easily reproducible environment and versioned representation of my environment I used Terraform to drive the deployment of all the resources.

The setup is very simple for now, I have 2 Terraform state:

  • low layer: Kubernetes cluster deployed on the TFGrid.
  • high layer: k8s resources to start the nodes (deployment, persistent volumes claims,… the usual k8s stuff)

At the end I managed to get everything working as expected. The only minor problem I had on the way way that I had to spend a bit of time finding a bunch of node that were accessible over Yggdrasil. I’m still not sure if it’s because my local Yggdrasil node took some time to discover the full network or if the nodes themselves have some connectivity issue. But after bit of pinging around and I managed to get enough working nodes to create my cluster.

Documentation was good enough for me. The wiki has a full example how to deploy a K8S cluster, you pretty much does not need anything else.

So the result of this first experiment can be found at https://github.com/zaibon/tfgridv3_collators
Feel free to explore and see how you can combine different building blocks to get to something bigger.

I know there are still some limitation, mainly regarding adding nodes to the cluster after creation etc… Hopefully this will be solved along the way.

It would be nice to have some example how to create huge data disk on the k8s cluster. Blockchain nodes usually requires terabytes of storage space which I was not really able to allocate in my cluster yet. Maybe 0-db-fs to the rescue for this ? (cc @maxux42)

This was a fun hacking session, I hope this will be useful for others :slight_smile:

4 Likes

That’s very cool! I’m glad!

QSFS will be definitely integrated within the terraform resources e.g https://library.threefold.me/info/manual/#/manual3_iac/grid3_terraform/manual__grid_terraform_qsfs, but things are still not solid yet, but will get there :slight_smile:

PS https://github.com/zaibon/tfgridv3_collators gives 404 Page not found