Do I need to format the disks before wipe them? (CLOSED)

Several days ago I powered on the server without disks to test it. It connected to the grid and as I expected it not showed any disks.
Today I took two ssd disks and wiped them as usual “sudo wipe -a /dev/sda1 and /dev/sdab1”, then stared Zero-OS but they can not be found. The disks are not formatted just wiped. My server is HP Proliant DL380p G8, RAID mode is disabled, updated BIOS.
My thoughts are about the first start time if it store some data about the node and does not update it when configuration changes. Also the disks nu be formatted before wiped.
Any suggestions colleagues?

sda1 is a sector, not the disk, try sda. A sata SSD is just 3 letters.


No you do not need to format the disks. You only need to wipe them. If you format them, Zero-OS won’t be able to boot properly the 3node.

You need to format the USB key before installing the Zero-OS Bootstrap image on it, but that is a completely different step than wiping the disks. For more information on this step, read 2. Create a Zero-OS Bootstrap Image here.

If you want the detailed steps on how to wipe the disks, read the section:

4. Wipe All the Disks

here: Threefold Farming Guide Part 1

Here’s the important part:

Once Linux is booted, go into the terminal and write the following command lines.

First, you can check the available disks by writing in a terminal or in a shell:


To see what disks are connected, write this command:

fdisk -l

If you want to wipe one specific disk, here we use sda as an example, write this command:

sudo wipefs /dev/sda

And replace the “a” by the letter of your disk, as shown when you did lsblk . The term sudo gives you the correct permission to do this.

To wipe all the disks in your 3node, write the command:

sudo for i in /dev/sd*; do wipefs -a $i; done

1 Like

Thanks guys for the help!
It is getting better. I wiped again the all disks. The first SSD appears - 3.5TB, it is SATA in the caddy. But the second 953.87GB is in the place of the DVD bay and is not found from the Zero-OS. I use m.2 adapter for it. Also tested it on another HP desktop computer which I use as another node, just replaced the adapters with and it is found and works fine.
I also changed some BIOS settings but nothing again.IMG_20220613_185509 IMG_20220613_185526 IMG_20220613_190047 IMG_20220613_104901 IMG_20220613_191057 IMG_20220613_191323IMG_20220613_190105

Its a crime to attach a NVME drive to a sata 2.0 connector. Get a PCIe adapter card for it.

1 Like

Following on Nelson’s thought, I think the DVD bay should only uses SATA SSD 2.5" disk.

It’s like having a F1 car on a max 50 MPH road, the NVME potential is limited with the DVD bay max cable speed.

If you have a NVME SSD disk, a PCIe adaptor like this should work on your HP server:

M.2 PCIe NVMe 4.0/3.0 Adapter

Screen Shot 2022-06-14 at 11.41.22 AM

The speed of transfer will be higher so that’s good.

If you want to use the DVD bay, a 2.5" SSD SATA III should work fine.

Let us know how it goes!

Actually my SSD is m.2 SATA III.

I have a 360 g8 and I had some trouble getting nvm drives to work, but I was able to get the 410i fully functional by using raid zero arrays under 1.2tb, I have both my sas drives and the ssd on the raid controller

Since your in a 2.5 a lot, go into raid config, delete all your logical drives and creat new raid zero arrays for each drive or groups under 1.2 tb.


I think that a m.2 adaptor for a SSD NVME or SSD SATA might not work with the DVD bay and that a standard 2.5" SATA SSD could.

For the m.2 SATA SSD, there are m.2 SATA SSD PCIe adaptors:

Screen Shot 2022-06-14 at 5.28.27 PM

@ParkerS’s solution is great too using raid zero.

@FLnelson on your 3node HP servers, the NVME SSD m.2 + PCie adaptor combination worked easily or you had to do some specific configurations?

No settings required.

1 Like

At least I figured out how to configure the disks.
HBA mode enabled and bought this adapter for the m.2 SATA disk. Then formatted and wiped all disks.
Now it is working fine.

1 Like

And you plugged it in the DVD bay right?

Nice to know you got it working igg!

In the HDD bay 2.5’’ caddy.

1 Like

@Mik you can add to the Threefold Farming Guide a notice for HP Proliant servers how to update the firmware to support XEON E5 - 2400, 2600, 4600 version 2 processors.

Are you sure the g8 can support v3 processors?

My mistake. Only version 2 support!

You tried this method and it works fine?

I added a short Q+A in the FAQ also with this video:

It should be enough for farmers to do the updates. Thanks for the proposition.

Yes I updated my server firmware to support these processors.

1 Like