Disk configuration

Hello,

So before I installed Zero OS I wiped clean all the storage drives and deleted all the partitions in the windows disk management tool, but I wasn’t sure if this was enough since after installing zero OS I didn’t see any mention of the storage on the screen, so I proceeded with the steps in the guide: installed grml linux distro and then run the command ‘‘for i in /dev/sd*; do parted -s $i mklabel msdos; dd if=/dev/zero of=$i bs=1M ; done’’. for about 3 hours it is just stuck doing it’s thing, and I don’t really know if it does something or not…!
IMG_0611|666x500
I have 4 HHDS total of 20 TB and 1 SSD of 1TB
Or maybe it was enough what I did with the disk management tool ?
pls hlp!

wait, why is my picture not showing ?

Hey @dan,

Zero OS doesn’t actually display available resources on the screen after boot (this is a common confusion, so I think a change may be in order).

Those commands to wipe the disks actually write zeros to the whole thing, which can take a very long time. I’m not sure if/why this is actually necessary to make storage available to Zos.

The way to know if your drives are being recognized is either to to the farm management tab in 3Bot or check your node in the explorer.

My best guess is that your photo isn’t loading because of it’s large size. I was able to download and view it.

For your reference, I’ve opened a couple issues on Github regarding things discussed here:


I see,
But how does CRU, MRU, HRU and SRU translate to units that we already know ?

If I make a guess CRU= CPU, MRU=RAM, HRU=HDD and SRU=SSD,
Am I righ?

If this is right, the only discrepancy I see is for the HRU. I have 20 TB of hdd but the HRU= 11178
here is another pic of my stats
IMG_0612
my machine has 8CPU 32 GB RAM 20 TB HDD and 1 TB SSD, does it seem about right ?

Ok, so I managed to bump up my HRU count above 18K, having 20TB it kinda makes sense now.
For those who want to know I used linux comand wipefs -a /dev/sdX where x is a,b,c,d, etc for how many hard drives you have. It takes seconds and it wipes out the filesystems on your drive, seems that this was the issue for me, since for 2 of my drives the filesystem was “Btrfs” whatever this is…

You can read up on resource units here: https://wiki.threefold.io/#/threefold__resource_units

Thanks for the report that wipefs worked for you. The btrfs filesystem is used by Zos, so it’s possible that this was created by your node at some point. Not sure why the node would then not recognize the drive though.

Hmm, ok, than probably the problem was with the other 2 drives that didn’t have the Btrfs filesystem. Anyways, it worked, I used the command on all hdds and ssds

Glad to hear it. Turns out there is a better way to clear the disks that I’ll be including in a troubleshooting guide.

1 Like