Dell WYSE 5070 Thin Client 3Node [RESOLVED]

Hello All,

Just found out about ThreeFold recently. I am interested in testing farming. However, I am having some issue getting my initial nodes online. The node boot fine using PXE and USB leveraging ZOS. However, the node never get past fetching realtime node information. The node does show up in monitoring portion of dashboard. I also wiped the SSD per a forum post, however same issue. I am wondering if it is the spec of the client(listed below) that maybe the cause of the issue. Per the Dashboard no write of read have happened on /dev/sda. I also have another 5070 with eMMC storage, but that seems like a non starter without SSD storage.

Storage - 64GB m.2 SATA SSD
Memory - 8 GB
CPU - J5005 Quad Core

Hi @elproducto

Good to know you’re exploring TF farming.

This post might interest you: Stuck on fetching realtime node information (Solved)

Relevant quotes:

“I had the same issue before; it works fine after rewiping all the disks and rebooting the node. Also, please deny sdb because it’s your running filesystem.”

“It seems using GRML to wipe the drives didn’t do a great job. I decided to restart the server and load Ubuntu live. I formatted the drives without partition. And made sure all drives were done this way. Then a reboot into 3node and it worked this time.”

To wipe the disk, try this guide perhaps:

I know you wrote that you did wipe your disks, but sometimes depending on how it’s done, it doesn’t work.

Let us know how it goes!

Your going to need a minimum of 500gb ssd aswell,

1 Like

Thanks for the link. I tried wipefs again, and also verified drive was wiped via GParted prior to reboot. No change still Fetching realtime node information… after waiting 30+ minutes. I did also match the setting for the Dell 7020 listed on the site, as most of those setting are available on the 5070. BIOS was updated to the latest version available. Additional wipes and testing was done using diskpart, and BIOS disk wipe option, no change.

I do want to callout after attempting boot, I rebooted the client to check partition information. The drive was partitioned to btrfs. Is this any indication ZOS did find the drive? As when verified prior to reboot drive was unallocated. Node is booting ZOS using PXE boot Test environment file

1 Like

I was hoping that was a recommendation for prod, as the page has “recommended setups”, but also has 500 GB is required. Is the lack of “500 GB of SSD” causing the issue my nodes is experiencing?

1 Like

Can you give us a pic of what you are seeing? I was also under the impression the 500gb was not mandatory.

1 Like

I have something in my head that tells me that ZOS reserves 100GB. Although it sounds a lot ( to me) but I have this number in my head… If true your 64GB wouldn’t be enough even for the OS… Also for 4 cores for maximum earning (gold ratio) you would need 400GB ssd (a little more because you never get 100% out of it)… and 32GB RAM…

1 Like

Nice catch guys.

Indeed zero-os needs 100GB for cache memory.

I think some farmers could make it run on less than 500GB of ram, say 400GB of ram, but 64Gb should be too little indeed. Thanks @ParkerS for spotting the obvious!

@elproducto can you try with a 500GB SSD minimum? This should do the trick.

As for @nooba pointed out, there are optimal ratios for farming. Here they are:

What is the optimal ratio of virtual cores (vcores or threads), SSD storage and RAM memory? What is the best optimization scenario for a 3node, in terms of Threefold tokens (TFT) farming rewards?

In short, for peak optimization, aim for 100 GB SSD of storage and 8GB RAM of memory per virtual core (vcore or thread).

For example, a 32 threads (32 vcores) 3nodes would need 3.2 TB SSD and 256GB RAM to be optimal, reward-wise. That is: 32 * 100 = 3200 GB SSD = 3.2TB SSD, and 32 * 8 = 256 GB RAM total.

Adding more GB of RAM would not increase your TFT rewards. You would need more vcores if you want to expand.

NB: This is purely based on reward considerations. Some users might need different ratios for different specific uses of the Grid.

It’s not “mandatory” as it can be played around a little, but too far from 500GB won’t boot I would guess.

Drives that are over 100gb but under 500gb I’ve have mixed results with, I do remember seeing a node on explorer with 240.

Normally I would expect it to say no cache dish found not just hang on registration in progress. Though this may be because the drive also needed a rewipe.

It’s difficult to say if upgrading the ssd would resolve your issue for sure but I suspect it would.

Yes @Mik you’re right 100GB of RAM not SDD of course… i got confused!!!

Hey @nooba I think you got it right. It’s 100GB of SSD for Zero-OS.
Not all 3nodes have more than 100GB of RAM. It’s a big number actually.

Thanks all for your assistance. Reviewed boot output. Noticed a few thing listed below. I will continue my testing once I get a bigger drive.

  • no debug disk found
  • BTRFS: device label devid 1 transid 11 /dev/sda scanned by udevd (266). /dev/sda is the drive in question
  • scsi host1: usb-storage 1-1.3:1.0. /dev/sda seems also to be on scsi bus? Could /dev/sda drive on scsi cause issue?
  • several wget: bad address ‘’. However further down something does get downloaded from google to /dev/null

If I remember well, the google thing not getting it right, right away, isn’t a problem.
It’s just the 3node pining

This shouldn’t be a concern.

Happy troubleshooting. You’ll see after this adventure you will boot a 3node in no time.
That’s the beauty of learning curves :stuck_out_tongue:

Yes, it’s normal to see a couple failures connecting to Google before a success, which is there.

I have one node running with a 128gb SSD, but I’ve never tried less than 100gb.

Once the node is booted and says “Fetching realtime node info”, you can connect a keyboard and hit alt-f1,f2 to look for any errors.

The btrfs filesystem suggests that Zos is access the disk okay, since that’s what it uses for its cache partition.

1 Like

@scott thanks for the additional troubleshooting step.

I did a netboot on a system with 128 GB of storage. I then did the Alt+F2 once fully booted. I saw what seem to be network related issues (errors listed below). Is there any adjustment needed to get past these errors?

First error is constantly repeating. Second error occurs after many occurrences of the the first error. Second error occur after Yggdrasil network setup dialog. I followed the steps to create the farm, so not sure what is up with the second error, I suspect it is related to the first error

error=“context deadline exceeded” module=network
error=failed to initialize rmb api failed to initialized admin mw: failed to get farm: farm not found: object not found

Can you try to boot with a USB and the bootstrap image?

If you can get it to work as simple as possible, then you can explore PXE.

Just an idea.

Maybe even just follow the link above from start, and just create a farm, bootstrap from USB, etc.

Changing the boot method won’t be relevant here, since the node has made it through bootstrap and is already running previously downloaded Zos code at this point.

Can you show a screenshot or two of what you’re seeing? We’ll need this to escalate to the dev team if necessary.

The other common gotcha with farms is that they only work on one network. Sometimes folks try to boot to testnet with their mainnet farm, for example. Can you confirm that the boot media/link you generated is for the same network that the farm is on?

1 Like

In earlier testing, I created a USB disk using test release, and ran into the same issues. However, I decided to use prod efi file release for network booting. Using prod release the 3Node successfully booted. :smiley:

For network booting I followed steps provide by @TheCaptain, linked below to setup my pfSense router.


Good to know you got it working!

For others reading this, the issue was trying a test net bootstrap image for a main net farm!

I’ll add [RESOLVED] to the post’s title.

Let us know if you have other issues or other questions.