Dell poweredge R720XD please help (CLOSED)

Morning all i need some one with a better brain than me. i have followed all the step in the 3 Node server guide but i can not get it to boot into Zero OS i have tried with a normal USB boot and a UIFI boot the closest i can get at the moment is to a screen “initializing network devices…” using the UIFI boot but it just hangs here. has anyone had this issue or may know a way round it please.

Use the ISO image file and make bootable USB. Boot your server using BIOS and not UEFI. In the boot sequence, make the USB as your first choice to boot.

thanks but i have already tried this and it does not boot

1 Like

did you use rufus to copy the CD iso to your usb sitck ?

yes it made no difference

are you able to just burn the iso to an actual CD and boot from that ? thats how I have been starting up my 720

You can try to boot from SD card.

Usually when you get this message booting in UEFI, you need to boot in BIOS mode.

All R720s boot from BIOS and not UEFI if I am not mistaken.


Are you using NVME SSD disks with PCIe adaptors, or you plugged Sata SSD disks in the onboard storage?

If the latter, you might need to re-flash as Nelson shows in the video above.

I have the R720xd no optical slot sadly

thanks i have tried booting in BIOS but no luck yet i will keep trying many thanks

Maybe try to burn the bootstrap image with balenaEtcher :

It will format the USB key in the process.

Screen Shot 2022-05-10 at 12.56.41 PM

Choose this option with BIOS mode, secure boot off.

Just shooting ideas trying to help.

How did you connect your SSD disk to the R720xd? Is it with pcie adaptor or the front panel disks?

Most of the time, this error is solved with the right combination (BIOS/UEFI and boot device). But sometimes, the cables are not plugged properly. For one farmer, it helped to unplug the SAS cables and plug in the SATA cables. That’s why I ask if you use the front panel for the SSD or the PCIE adaptor.

i am using m.2 nvme ssd

1 Like

OK thanks for the reply. m.2 nvme ssd should be easier than having ssd in the onboard storage.

Can you try resetting the BIOS?

Also, updating to the latest version the firmware, motherboard, bios, can really help in those situations.

As @igg stated, trying with the SD card could work.

Maybe the USB port is broken or malfunctioning.

“initializing network devices” means the computer wants to open the booting device you set up, but can’t so it gets stuck there.

have you tried selecting your boot device manually? it sounds like you may be seeing your network cards attempt a boot from net.

I had some trouble with a similar issue when i was testing on an older server. i was able to get it working by using Rufus to image the flash drive with a bios boot image and setting it to DD mode.


thanks but this did not work.

I will give this a go thank you

Update. So it turns out that i was being very silly. Do not connect server to TV as a short cut it has just cost me 18 days of pain and hassle. thank you for all the help

Hey @willyt ! Glad to know it finally worked. Don’t worry we all start doing silly mistakes. Good news is that’s one of the best way to learn!

For documentation purpose, can you elaborate more on what was the issue and what fixed it?

You were connecting the 3node to a TV set instead of a standard computer monitor, and it froze at “initializing network devices…” then when you plugged into a standard monitor, it worked? Was it a HDMI connection for the TV? Some farmers did have trouble booting with a HDMI cable, that’s why I ask.

Thanks for your time… and happy farming!